Aerospike Connect for Presto - Trino Release Notes

  • Trino 3.2.0
    Release Date: April 25, 2022
    • Trino 3.2.0 - Supported until July 25th, 2023.
    • If you are using Trino (formerly known as PrestoSQL), ensure that you are using a compatible version of the the Presto connector.

    New Features

    • [CONNECTOR-144] - Support Aerospike secondary indexes. This feature requires server version 6.0+.
    • Upgrade Trino to 378.
    • Upgrade Aerospike Java client to 6.0.0.
    • Upgrade dependencies.

  • Trino 3.1.0
    Release Date: March 3, 2022
    • Trino 3.1.0 - Supported until June 3rd, 2023.
    • If you are using Trino (formerly known as PrestoSQL), ensure that you are using a compatible version of the the Presto connector.

    New Features

    • [CONNECTOR-333] - Rename audit log event listener to resolve conflict with Starburst.
    • Upgrade Trino to 372.
    • Upgrade dependencies.

  • Trino 3.0.0
    Release Date: February 15, 2022
    • Trino 3.0.0 - Supported until May 15th, 2023.
    • If you are using Trino (formerly known as PrestoSQL), ensure that you are using a compatible version of the the Presto connector.

    New Features

    • Upgrade Trino to 370.
    • Upgrade dependencies.

    Bug Fixes

    • Fix deprecation warnings.

  • Trino 2.0.0
    Release Date: February 4, 2022
    • Trino 2.0.0 - Supported until May 4th, 2023.
    • If you are using Trino (formerly known as PrestoSQL), ensure that you are using a compatible version of the the Presto connector.

    New Features

    • Allow and ignore empty string values in configuration file.
    • Update modernizer exclusion patterns.
    • Add cause to TrinoException in AerospikeTLSPolicyBuilder.
    • Upgrade Trino to 369.
    • Upgrade dependencies.

    Bug Fixes

    • Fix Modernizer warning.

  • Trino 1.9.0
    Release Date: April 25, 2022
    • Trino 1.9.0 - Supported until July 25th, 2023.
    • If you are using Trino (formerly known as PrestoSQL), ensure that you are using a compatible version of the the Presto connector.

    New Features

    • [CONNECTOR-144] - Support Aerospike secondary indexes. This feature requires server version 6.0+.
    • Upgrade Aerospike Java client to 6.0.0.
    • Upgrade dependencies.

  • Trino 1.8.0
    Release Date: March 3, 2022
    • Trino 1.8.0 - Supported until June 3rd, 2023.
    • If you are using Trino (formerly known as PrestoSQL), ensure that you are using a compatible version of the the Presto connector.

    New Features

    • [CONNECTOR-333] - Rename audit log event listener to resolve conflict with Starburst.

  • Trino 1.7.0
    Release Date: February 4, 2022
    • Trino 1.7.0 - Supported until May 4th, 2023.
    • If you are using Trino (formerly known as PrestoSQL), ensure that you are using a compatible version of the the Presto connector.

    New Features

    • Allow and ignore empty string values in configuration file.
    • Update modernizer exclusion patterns.
    • Add cause to TrinoException in AerospikeTLSPolicyBuilder.
    • Upgrade Trino to 368.
    • Upgrade dependencies.

    Bug Fixes

    • Fix Modernizer warning.

  • Trino 1.6.0
    Release Date: December 22, 2021
    • Trino 1.6.0 - Supported until March 22th, 2023.
    • If you are using Trino (formerly known as PrestoSQL), ensure that you are using a compatible version of the the Presto connector.

    New Features

    • Utilize the Netty native transports for the Aerospike Java client.
    • Upgrade Aerospike Java client to 5.1.11.
    • Upgrade Trino to 366.

  • Trino 1.5.0
    Release Date: October 24, 2021
    • Trino 1.5.0 - Supported until January 24th, 2023.
    • A bug affecting this version of the Trino Connector has been identified, we strongly recommend that you upgrade to Aerospike Connect for Trino 1.6.0 at the earliest opportunity.
    • If you are using Trino (formerly known as PrestoSQL), ensure that you are using a compatible version of the the Presto connector.

    New Features

    • [CONNECTOR-299] - Add Audit Trail capability.
    • [CONNECTOR-300] - Add record's digest as a column.
    • Upgrade Aerospike Java client to 5.1.8.
    • Upgrade Trino to 363.

    Bug Fixes

    • Fix Filter Expressions for primary keys.

  • Trino 1.4.1
    Release Date: September 20, 2021
    • Trino 1.4.1 - Supported until December 20th, 2022.
    • A bug affecting this version of the Trino Connector has been identified, we strongly recommend that you upgrade to Aerospike Connect for Trino 1.6.0 at the earliest opportunity.
    • If you are using Trino (formerly known as PrestoSQL), ensure that you are using a compatible version of the the Presto connector.

    Bug Fixes

    • Support case insensitive namespaces.

  • Trino 1.4.0
    Release Date: September 17, 2021
    • Trino 1.4.0 - Supported until December 17th, 2022.
    • A bug affecting this version of the Trino Connector has been identified, we strongly recommend that you upgrade to Aerospike Connect for Trino 1.6.0 at the earliest opportunity.
    • If you are using Trino (formerly known as PrestoSQL), ensure that you are using a compatible version of the the Presto connector.

    New Features

    • [CONNECTOR-288] - Support case insensitive identifiers.
    • Upgrade Trino to 361.

    Improvements

    • Document the PKI authentication mode.

    Bug Fixes

    • Use the next event loop on scans.
    • Fix the primary key column type inference.

  • Trino 1.3.0
    Release Date: August 21, 2021
    • Trino 1.3.0 - Supported until November 21th, 2022.
    • A bug affecting this version of the Trino Connector has been identified, we strongly recommend that you upgrade to Aerospike Connect for Trino 1.6.0 at the earliest opportunity.
    • If you are using Trino (formerly known as PrestoSQL), ensure that you are using a compatible version of the the Presto connector.

    New Features

    • Upgrade Trino to 360.

  • Trino 1.2.0
    Release Date: August 15, 2021
    • Trino 1.2.0 - Supported until November 15th, 2022.
    • A bug affecting this version of the Trino Connector has been identified, we strongly recommend that you upgrade to Aerospike Connect for Trino 1.6.0 at the earliest opportunity.
    • If you are using Trino (formerly known as PrestoSQL), ensure that you are using a compatible version of the the Presto connector.

    New Features

    • Upgrade Trino to 358
    • Upgrade Aerospike Java client to 5.1.7
    • Upgrade Netty to 4.1.66.Final

  • Trino 1.1.0
    Release Date: July 1, 2021
    • Trino 1.1.0 - Supported until October 1st, 2022.
    • A bug affecting this version of the Trino Connector has been identified, we strongly recommend that you upgrade to Aerospike Connect for Trino 1.6.0 at the earliest opportunity.
    • If you are using Trino (formerly known as PrestoSQL), ensure that you are using a compatible version of the the Presto connector.

    New Features

    • [CONNECTOR-146] - Enable sending boolean type for a boolean bin.
    • [CONNECTOR-206] - Add a retry mechanism on retriable errors.
    • Upgrade Trino to 357.
    • Upgrade Aerospike Java client to 5.1.3.

    Improvements

    • Dockerize the connector.
    • Document retry configuration properties.
    • Improve documentation.

    Bug Fixes

    • Resolve the obsolete Marker in the new Trino version.
    • Fix the get by primary key functionality.
    • Throw TrinoException on an Aerospike asynchronous command failure.

  • Trino 1.0.0
    Release Date: February 17, 2021
    • Trino 1.0.0 - Supported until May 17th, 2022.
    • Aerospike Connect for Presto - Trino (formerly known as Aerospike Connect for Presto - PrestoSQL).
    • Initial General Availability release for Aerospike Database Enterprise Edition version 4.9 and above.
    • A bug affecting this version of the Trino Connector has been identified, we strongly recommend that you upgrade to Aerospike Connect for Trino 1.6.0 at the earliest opportunity.
    • If you are using Trino (formerly known as PrestoSQL), ensure that you are using a compatible version of the the Presto connector.

  • PrestoSQL 1.0.0
    Release Date: January 14, 2021
    • PrestoSQL 1.0.0 - Supported until May 14th, 2022.
    • Initial General Availability release for Aerospike Database Enterprise Edition version 4.9 and above.
    • A bug affecting this version of the Presto - Trino Connector has been identified, we strongly recommend that you upgrade to Aerospike Connect for Trino 1.6.0 at the earliest opportunity.