XDR-Proxy Release Notes

  • 2.0.0
    Release Date: April 4, 2022

    New Features

    • [CONNECTOR-340] - Provide an option for in-order delivery of different versions of the same record.

    Improvements

    • [CONNECTOR-341] - Performance and stability improvements.
    • [CONNECTOR-342] - Vulnerability scanning and dependency upgrades.
    • [CONNECTOR-343] - Single installer for HTTP and XDR 5.0 wire protocol connector.

  • 1.2.0
    Release Date: February 4, 2022

    Improvements

    • [CONNECTOR-320] - Support Java 17 runtime.
    • [CONNECTOR-326] - Support all XDR wire format options and flags. This feature enables support for bin deletions.

  • 1.1.1
    Release Date: July 14, 2021

    Improvements

    • Upgrade external dependencies.

  • 1.1.0
    Release Date: May 24, 2021
    • ATTENTION: HTTP connectors renamed from aerospike-xdr-proxy-legacy to aerospike-xdr-proxy-http. Refer to documentation for installation and starting instructions.

    New Features

    • Prometheus integration support.
    • Pre-packaged Grafana dashboards.
    • PEM file format support in TLS configuration.
    • Official container image available on Docker Hub.

    Bug Fixes

    • Handling of new particle types introduced by the Aerospike Server not recognized by the connector.

  • 1.0.0
    Release Date: August 10, 2020
    • ATTENTION Upgrade to aerospike-xdr-proxy 1.1.0 or later when using Aerospike 5.6 Server or later.
    • Initial General Availability release for Aerospike Server Enterprise Edition version 5.0 and above.
    • Legacy support for versions of the Aerospike Server Enterprise Edition version 4.9 and below.
      • If using Aerospike Server version 4.9 or below the Legacy connector must be used.
      • WARNING: A serious flaw has been discovered for http v2 in the library used by Aerospike Server Enterprise < 5.0 change notification. http-version MUST be set to v1 to prevent xdr and change notification from being blocked.

    Known Issues

    • JDK-8 XDR proxy crashes when consuming records from Aerospike Server 5.6 or later.
    • JDK-11 XDR proxy errors on every record consumed from Aerospike Server 5.6 or later.